Debian : Upgrade MySQL 5.1 Sub-process /usr/bin/dpkg returned an error code (1)

Classé dans Outils

ça pueEn upgradant ce soir mon serveur Debian, j'ai eu la mauvaise suprise de tomber sur l'erreur ci-dessus . Après maintes recherches, voici la solution que je vous apporte sur un plateau...

L'upgrade du serveur Mysql 5.0 vers la version 5.1 plantait inexorablement. Jusqu'à ce que je trouve la ligne salvatrice dans les pages de ce forum zibou

Il suffit simplement de vérifier que le loopback se fait bien dans l'interface ip. Pour se faire, désactivez le port éthernet utilisé (chez moi eth0), ouvrez votre éditeur préféré, et vérifiez le fichier /etc/network/interfaces :

ifdown eth0
nano /etc/network/interfaces

Vérifiez que vous ayez bien :

#The loopback network interface
auto lo eth0
iface lo inet loopback

Puis, réactivez le port éthernet 0

ifup eth0

Upgradez

apt-get update
apt-get upgrade

Redémarrez

shutdown -r now

Et tout devrait rentrer dans l'ordre.

J'espère que cette astuce vous évitera des heures de recherche inutiles.

Note pour plus tard : ne plus lancer de mise à jour à une heure du mat endormi

1 commentaire

  1. Oui Cyril il faut pas oublier de dormir la nuit :-P

Écrire un commentaire

*


*

 Se rappeler de moi sur ce site

*
Quelle est la deuxième lettre du mot rjmj ? :